Kashif Nizam Qureshi

Email Error / Issues in SharePoint and Project Server

Leave a comment

Project Server Workflow Email:
I have clubbed together all the issue/errors related to workflow emails.

Workflow status was showing following error.

Retrying last request. Next attempt scheduled in less than one minute. Details of last request: HTTP InternalServerError to http://server/PWA/_vti_bin/client.svc/sp.utilities.utility.SendEmail Correlation Id: 8108ea7a-3466-4da4-a8ad-4a88f6a1ea20 Instance Id: a6cb140e-edba-4a64-ac6f-6df21fd8c14f

Retrying last request. Next attempt scheduled in less than one minute. Details of last request: HTTP InternalServerError to http: //epmtest/PWA/_vti_bin/client.svc/sp.utilities.utility.SendEmail Correlation Id: 244a2044-745c-752d-b569-595cf56c5c0d Instance Id: 134a1388-7cf3-4122-a07d-f8b524617df3

After few minutes….

RequestorId: 63ac78dc-888c-a459-0000-000000000000. Details: An unhandled exception occurred during the execution of the workflow instance. Exception details: System.ApplicationException: HTTP 500 {“Transfer-Encoding”:[“chunked”],”X-SharePointHealthScore”:[“4″],”SPClientServiceRequestDuration”:[“6″],”SPRequestGuid”:[“63ac78dc-888c-a459-8685-187110c0fbfe”],”request-id”:[“63ac78dc-888c-a459-8685-187110c0fbfe”],”X-FRAME-OPTIONS”:[“SAMEORIGIN”],”MicrosoftSharePointTeamServices”:[“15.0.0.4617″],”X-Content-Type-Options”:[“nosniff”],”X-MS-InvokeApp”:[“1; RequireReadOnly”],”Cache-Control”:[“max-age=0, private”],”Date”:[“Fri, 19 Dec 2014 18:56:24 GMT”],”Server”:[“Microsoft-IIS\/8.5″],”X-AspNet-Version”:[“4.0.30319″],”X-Powered-By”:[“ASP.NET”]} at Microsoft.Activities.Hosting.Runtime.Subroutine.SubroutineChild.Execute(CodeActivityContext context) at System.Activities.CodeActivity.InternalExecute(ActivityInstance instance, ActivityExecutor executor, BookmarkManager bookmarkManager) at System.Activities.Runtime.ActivityExecutor.ExecuteActivityWorkItem.ExecuteBody(ActivityExecutor executor, BookmarkManager bookmarkManager, Location resultLocation)

Though, email was configured at PWA and Web application level but still had to be configured at farm level to solve this error.

Courtesy: http://ppmworks.com/project-server-workflow-send-email-action-was-not-working-correctly/

Advertisements

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s