Kashif Nizam Qureshi


Leave a comment

Error occurred in deployment step Activate Features

If deploying WSP using Visual Studio, you’ll end up with the following error.

Error occurred in deployment step ‘Activate Features’: Feature with Id ‘8a442317-1158-4994-b265-26499b2def57’ is not installed in this farm, and cannot be added to this scope.

Solution:

Just manually created package and deploy

Courtesy:
http://blogs.msdn.com/b/calvarro/archive/2011/11/06/sharepoint-2010-amp-visual-studio-2010-error-ocurred-activate-features-feature-with-id-installed-in-this-farm-cannot-be-added-to-this-scope.aspx


Leave a comment

SharePoint 2013 Designer Workflow Error Access Denied

Starting up a list workflow, was throwing following error.

Error:

RequestorId: 675358e8-c91d-0f3a-ebaa-d663a9a1202d. Details: System.ApplicationException: HTTP 401 {“error”:{“code”:”-2147024891, System.UnauthorizedAccessException”,”message”:{“lang”:”en-US”,”value”:”Access denied. You do not have permission to perform this action or access this resource.”}}} {“Transfer-Encoding”:[“chunked”],”X-SharePointHealthScore”:[“0″],”SPRequestGuid”:[“6359f5a3-808a-4144-ace2-0fdff207809f”],”request-id”:[“6359f5a3-808a-4144-ace2-0fdff207809f”],”X-FRAME-OPTIONS”:[“SAMEORIGIN”],”MicrosoftSharePointTeamServices”:[“15.0.0.4569″],”X-Content-Type-Options”:[“nosniff”],”X-MS-InvokeApp”:[“1; RequireReadOnly”],”Cache-Control”:[“max-age=0, private”],”Date”:[“Sun, 30 Nov 2014 08:08:36 GMT”],”Server”:[“Microsoft-IIS\/8.0″],”WWW-Authenticate”:[“NTLM”],”X-AspNet-Version”:[“4.0.30319″],”X-Powered-By”:[“ASP.NET”]} at Microsoft.Activities.Hosting.Runtime.Subroutine.SubroutineChild.Execute(CodeActivityContext context) at System.Activities.CodeActivity.InternalExecute(ActivityInstance instance, ActivityExecutor executor, BookmarkManager bookmarkManager) at System.Activities.Runtime.ActivityExecutor.ExecuteActivityWorkItem.ExecuteBody(ActivityExecutor executor, BookmarkManager bookmarkManager, Location resultLocation)

Resolution 1:

PS C:\Users\exceed.epm> Get-SPTimerJob “RefreshMetadataFeed” | Start-SPTimerJob

Resolution 2 (In my case it worked):

Activate site feature “Workflows can use app permissions

Site actions > Site Settings > Site features > Workflows can use app permission

[Updates 10-08-2016]

Resolution 3:

This time above two resolution didn’t work. Had to install CU3 of Workflow Manager and Client.